CalaisTurbo New Tags
User Name: Password:

Go Back   calaisturbo.com.au > calaisturbo.com.au > VL Non-Turbo Discussion
JD CUSTOM

Reply

 

Thread Tools
Old 04-01-18, 13:56   #1
fleas
COLONY SAVAGE
 
fleas's Avatar
 
Join Date: 18-05-05
Location: NSW, Wollongong
Car: 1988 Executive; 1987 Executive
Trader Rating: (27)
Starting VL after almost 10 months

Hi and apologies if this has been posted before-couldn't find anything.

Apart from an oil change, oil filter replacement, spark plugs servicing, what other things should I look out for?

I've also sprayed some lubricant after removing the spark plugs.

Should I syphon the fuel as well (to be frank I think it might have evaporated)

Also would there be a need to turn the engine, I don't know how to do this manually
?

Thanks in advance
__________________
A lie is a lie even if everyone believes it; the truth is the truth even if no one believes it
fleas is offline   Reply With Quote
Old 05-01-18, 12:02   #2
OriginalG
Player
 
Join Date: 10-02-15
Location: NSW, Lost
Car:
Trader Rating: (0)
If you left fuel in it it wont have just evaporated, the new fuels go bad unlike the old days and probably rooted fuel lines and pump. Learnt the hard way with mine last year.

If its already starting with whats there and you're getting coughing and stuttering before cutting out after so long probably the fuel also.

Would drop the tank and drain it.
OriginalG is offline   Reply With Quote
Old 05-01-18, 20:45   #3
deanoVLCT
MODERATERRRRR
 
deanoVLCT's Avatar
 
Join Date: 05-01-05
Location: Melbourne, City
Car: Car: Hq gts coupe - Vl Sl turbo bt1 - Vl nitron - Vl v8 1k001 berlina - Fg xr6 ute - LJ coupe - LX slr 5000 rep
Trader Rating: (24)
Fleas, kick it in the guts brother
RB30 tough as nails
deanoVLCT is offline   Reply With Quote
Old 06-01-18, 16:52   #4
fleas
COLONY SAVAGE
 
fleas's Avatar
 
Join Date: 18-05-05
Location: NSW, Wollongong
Car: 1988 Executive; 1987 Executive
Trader Rating: (27)
Quote:
Originally Posted by OriginalG View Post
If you left fuel in it it wont have just evaporated, the new fuels go bad unlike the old days and probably rooted fuel lines and pump. Learnt the hard way with mine last year.

If its already starting with whats there and you're getting coughing and stuttering before cutting out after so long probably the fuel also.

Would drop the tank and drain it.
Thanks for the heads up man; I poured fresh fuel in. Everything else looks the goods with regards to fuel lines, hoses, etc.

I had a spare fuel filter laying around so I replaced it aswell.


Deano, yeah that's it mate. Will see how we go aye :P
__________________
A lie is a lie even if everyone believes it; the truth is the truth even if no one believes it
.
fleas is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +10. The time now is 17:42.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Ad Management plugin by RedTyger