CalaisTurbo New Tags
User Name: Password:

Go Back   calaisturbo.com.au > Technical > LPG GAS Specific
Oz Drive - Driver Education

Reply

 

Thread Tools
Old 02-07-10, 20:53   #1
stiffy21
Player
 
stiffy21's Avatar
 
Join Date: 26-06-10
Location: VIC, western suburbs
Car:
Trader Rating: (0)
backfire and blowing airbox

hey guys just after some help with my gas system that often wen i give it to it the air box blows. any ideas how to fix this problem?
stiffy21 is offline   Reply With Quote
Old 03-07-10, 01:41   #2
fishy840
Player
 
fishy840's Avatar
 
Join Date: 25-09-08
Location: Melbourne, south east
Car:
Trader Rating: (0)
possibly check spark plugs and ignition leads and replace as required and regap spark plugs to 0.8mm
fishy840 is offline   Reply With Quote
Old 03-07-10, 10:37   #3
Matt.
Player
 
Matt.'s Avatar
 
Join Date: 20-05-10
Location: VIC, South Gippsland.
Car: 1988 VL Vacationer Sedan.
Trader Rating: (1)
Is it happening to a VT?
cos my mum had the same problem, pretty sure it went in to get fixed, tho I never asked what the problem turned out to be, I'll find out later and let you know.
Matt. is offline   Reply With Quote
Old 04-07-10, 10:59   #4
LUXJET
yehboi
 
LUXJET's Avatar
 
Join Date: 17-09-06
Location: VIC, 3268
Car: PANNIC
Trader Rating: (5)
yeah happening to my vs too.. im thinking change the plugs n leads and a $80 tune will fix it..
__________________
Bitches be trippin
.
LUXJET is offline   Reply With Quote
Old 04-07-10, 18:12   #5
stiffy21
Player
 
stiffy21's Avatar
 
Join Date: 26-06-10
Location: VIC, western suburbs
Car:
Trader Rating: (0)
k thx heaps guys. btw matt its a vx but i doubt it will be that much of a difference anyway
\
stiffy21 is offline   Reply With Quote
Old 05-07-10, 14:53   #6
Matt.
Player
 
Matt.'s Avatar
 
Join Date: 20-05-10
Location: VIC, South Gippsland.
Car: 1988 VL Vacationer Sedan.
Trader Rating: (1)
Found out.. Apparently it was the leads.
Matt. is offline   Reply With Quote
Old 12-10-10, 12:51   #7
CK-1991
Player
 
Join Date: 12-10-10
Location: Melbourne, Hoppers Crossing
Car:
Trader Rating: (0)
@ Matt
i had the same problem after having LPG installed on my vt
but for me after i changed plugs and leads and it was still doing it, it turned out the guy who tuned it was running gas to lean.

adjusted it and it's all good now!
CK-1991 is offline   Reply With Quote
Old 03-06-11, 00:30   #8
VQ355
Player
 
Join Date: 05-05-11
Location: VIC, Echuca
Car: VQ 1993 355 Stroker
Trader Rating: (0)
a motor that has a slight miss running on lpg with backfire alot, be careful if you wash under the bonnet, same will happen if the leads get wet.
new plugs and leads should fix it everytime
VQ355 is offline   Reply With Quote
Old 29-08-11, 21:50   #9
vlturbobo
Player
 
vlturbobo's Avatar
 
Join Date: 09-02-05
Location: Melbourne, Ballarat
Car: 97 ford mondeo wagon glx & vl calais series II in the build
Trader Rating: (2)
Send a message via MSN to vlturbobo
itll continu 2 happen, just do what i did. get a valve put into the airbox. 99% of gas joints sell em, and when it backfires the valve will pop open venting out the backfire and leaving the airbox intact.
vlturbobo is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +10. The time now is 01:06.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Ad Management plugin by RedTyger