View Full Version : Alternator not charging battery


Macheda
06-10-06, 20:13
Hey guys,

I have recently finished putting my engine back into my VL i connected everything and got everything going, but for some reason my alternator will not charge my battery. The alternator is earthed, the power wire is connected to the nut on the back of the alternator, the two wire plug that plugs into the bottom of the alternator is plugged in and my block (engine) and chassis is earthed.

I can't work out why it isn't charging the battery. It was working good before the engine was taken out.

Any help would be greatly appreciated.

Thanks Macheda

JoshV8inj
06-10-06, 20:41
could be the regulator has packed it in, your battery light should come on if this is the case? Ive bought these brand new before and theyve been rooted. (there the black square thing that screws into the back of the alternator.

Macheda
06-10-06, 20:53
oh ok thanks for that

i had to buy a brand new plug with those 2 long springy things that look like charcoal lol that the plug with two wires plugs into, so i definitely know its not that. i have got a second hand alternator here so i will swap that black box over onto my alternator see how it goes. oh and the battery light does come on on the dash

Thanks for that JoshV8inj

Macheda

JoshV8inj
06-10-06, 22:52
oh ok thanks for that

i had to buy a brand new plug with those 2 long springy things that look like charcoal lol that the plug with two wires plugs into, so i definitely know its not that. i have got a second hand alternator here so i will swap that black box over onto my alternator see how it goes. oh and the battery light does come on on the dash

Thanks for that JoshV8inj

Macheda

That plug with the 2 springy things should be the regulator lol. I am thinking of the bosch alternator however so if you have a hitatchi it may be a bit different. If changing that black box doesnt work then yes, get another regulator. as stated before they arent uncomman to be faulty as a new part ;)

JET-6
07-10-06, 00:38
Do you have your dash out?

Macheda
07-10-06, 15:59
No sorry my dash is in i havn't had a chance to hav a look at the alternator yet so i will have a look tomorrow thanks for your help guys!

JET-6
07-10-06, 19:34
If the globe is blown in the dash or the light does not work the alt will not charge

Macheda
08-10-06, 11:43
Yea the battery light on the dash does come on, so it isn't blown i am just about to have a look at it so i will get back to you on how i go

Thanks